ACM-ICPC 2018 徐州赛区网络预赛

Characters with Hash

问答

  • 26.45%
  • 1000ms
  • 262144K

Mur loves hash algorithm, and he sometimes encrypt another one’s name, and call him with that encrypted value. For instance, he calls Kimura KMR, and calls Suzuki YJSNPI. One day he read a book about SHA-256256 , which can transit a string into just 256256 bits. Mur thought that is really cool, and he came up with a new algorithm to do the similar work. The algorithm works this way: first we choose a single letter L as the seed, and for the input(you can regard the input as a string ss, s[i]s[i] represents the iith character in the string) we calculates the value(|(int) L - s[i]|∣(int)L−s[i]∣), and write down the number(keeping leading zero. The length of each answer equals to 22because the string only contains letters and numbers). Numbers writes from left to right, finally transfer all digits into a single integer(without leading zero(ss)). For instance, if we choose ‘z’ as the seed, the string “oMl” becomes “1111 4545 1414”.

It’s easy to find out that the algorithm cannot transfer any input string into the same length. Though in despair, Mur still wants to know the length of the answer the algorithm produces. Due to the silliness of Mur, he can even not figure out this, so you are assigned with the work to calculate the answer.

Input

First line a integer TT , the number of test cases (T \le 10)(T≤10).

For each test case:

First line contains a integer NN and a character zz, (N \le 1000000)(N≤1000000).

Second line contains a string with length NN . Problem makes sure that all characters referred in the problem are only letters.

Output

A single number which gives the answer.

样例输入复制

1
2
3
4
5
2
3 z
oMl
6 Y
YJSNPI

样例输出复制

1
2
6
10

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
#include<bits/stdc++.h>
using namespace std;
char str[1000007],ch[2];
int main(){
int t,n;
scanf("%d",&t);
while(t--){
scanf("%d%s%s",&n,ch,str);
int ans = 2*n;
for(int i = 0; i<n; i++){
if(str[i]==ch[0])
ans-=2;
else{
if(abs(str[i]-ch[0])<10)
ans-=1;
break;
}
}
if(ans==0)
ans++;
printf("%d\n",ans);
}
return 0;
}

文章结束了,但我们的故事还在继续
坚持原创技术分享,您的支持将鼓励我继续创作!